Friday, 23 November 2012

Your system does not support long mode

Just a quick note for anyone who may come across a similar issue when trying to deploy server images on to their VMWare environment.

I've been lucky enough to get a new server recently to test various virtual WLCs and management packages that are being put out by various wireless vendors. But after installing ESXi and deploying a couple of server images, when I tried to start the virtual servers up, I kept getting the following messages popping up in vShere:


(For search engine benefit: This virtual machine is configured for 64-bit operating systems. However, 64-bit operation is not possible. Longmode is not possible. Longmode is disabled for this virtual machine)

Also, in the console of the server (Cisco MSE & NCS), I was getting the following reported: "Your CPU does not support long mode. use a 32 bit distribution"

I was concerned that maybe there was an issue with my server CPU, in terms of support for virtualization. 

I rebooted the server and dropped in to the BIOS setup and found that the virtualization parameter for the processor settings was set to disabled! So, I enabled it and rebooted. But, the issue persisted :(

So, I dropped in to the BIOS setup again and noticed a little note that said that a complete power-off was required once the virtualization setting had been changed.

A few minutes later, after a complete power off, my virtual servers were finally booting correctly!

Probably a complete noobie error, but we've all got to start somewhere :)